Accessing ROS

Trying to upload some returns all day and the revenue plugin is regularly crashing the site.  Are they having particular issues at the moment or does this happen regularly.

1 answer

Peter Connor Staff March 3, 2014


I just tried opened the ROS site in Bullet with no issue. It’s just an iframe that sites with in our page.
Have you tried to just upload it to ROS outside of Bullet, here is the address
You’ll find your tax xml files in your downloads folder on your computer. 
Let me know how you get on, we’ll keep checking it here. 

  1. osullio3 March 3, 2014
    I had difficulty accessing it directly on the ROS site as well.
  2. Peter Connor March 3, 2014
    Ok, sounds like ROS. Did you try a different browser, and/or reboot your machine? ROS looks for a digital cert on your machine and that can always cause problems.

    Let me know

  3. osullio3 March 3, 2014
    Good point. I'll give that a go.
  4. Peter Connor March 3, 2014
    Cool, Let me know.
  5. osullio3 March 3, 2014
    Got in, now a question about VAT3 forms. When I upload the form is it meant to include all the data required by revenue. I'm getting directed to enter the amounts manually at the various different VAT rates.
  6. Peter Connor March 3, 2014

    You are probably been shown the end of year VAT RTD screen (your VAT RTD is your yearly VAT breakdown). You can skip that and just upload the VAT3 file as normal. You will need to return at a later date and fill out your VAT RTD.

    Here are all the corporate taxes explained

    Let me know if that helps.


Please login or Register to Submit Answer